トップ «前の日記(2012-02-14) 最新 次の日記(2012-02-16)» 編集

ヨタの日々

2001|08|09|10|11|12|
2002|01|02|03|04|05|06|07|08|09|10|11|12|
2003|01|02|03|04|05|06|07|08|09|10|11|12|
2004|01|02|03|04|05|06|07|08|09|10|11|12|
2005|01|02|03|04|05|06|07|08|09|10|11|12|
2006|01|02|03|04|05|06|07|08|09|10|11|12|
2007|01|02|03|04|05|06|07|08|09|10|11|12|
2008|01|02|03|04|05|06|07|08|09|10|11|12|
2009|01|02|03|04|05|06|07|08|09|10|11|12|
2010|01|02|03|04|05|06|07|08|09|10|11|12|
2011|01|02|03|04|05|06|07|08|09|10|11|12|
2012|01|02|03|04|05|06|07|08|09|10|11|12|
2013|01|02|03|04|05|06|07|08|09|10|11|12|
2014|01|02|03|04|05|06|07|08|09|10|11|12|
2015|01|02|03|04|05|06|07|08|09|10|11|12|
2016|01|02|03|04|05|06|07|08|09|10|11|12|
2017|01|02|03|04|05|06|07|08|09|10|11|12|
2018|01|02|03|04|05|06|07|08|09|10|11|12|
2019|01|02|03|04|05|06|07|08|09|10|11|12|
2020|01|02|03|04|05|06|07|08|09|10|11|12|
2021|01|02|03|04|05|06|07|08|09|10|11|12|
2022|01|02|03|04|05|06|07|08|09|10|11|12|
2023|01|

2012-02-15 :-(

_ 午前

0520 起床

0830 出勤

0900 テスト準備

_ 午後

1300 テスト準備

1500 外出

1530 自社 || 打ち合わせ

1700 退勤

_

1900 rubyほげ

2030 飯

2230 rubyほげ

_ cygwin が死んだ

たぶん rebaseall すればいいんだけど

% bundle exec rake spec
/usr/local/lib/ruby/1.9.1/yaml.rb:56:in `<top (required)>':
It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your ruby.
/usr/local/lib/ruby/1.9.1/yaml.rb:56:in `<top (required)>':
It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your ruby.
/usr/local/bin/ruby.exe -S rspec spec/acceptance/append_comment_spec.rb spec/acceptance/append_diary_spec.rb spec/acceptance/bugfix/encoding_error_spec.rb                        spec/acceptance/save_conf_comment_spec.rb spec/acceptance/save_conf_default_spec.rb spec/acceptance/save_conf_dnsbl_spec.rb spec/acceptance/save_conf_fil                       ter_spec.rb spec/acceptance/save_conf_plugin_spec.rb spec/acceptance/save_conf_referer_spec.rb spec/acceptance/save_conf_security_spec.rb spec/acceptance/                       update_diary_spec.rb spec/acceptance/view_category_spec.rb spec/acceptance/view_comment_spec.rb spec/acceptance/view_diary_spec.rb spec/acceptance/view_re                       ferer_spec.rb spec/core/compatible_spec.rb spec/core/core_ext_spec.rb spec/core/style/emptdiary_style_spec.rb spec/core/style/etdiary_style_spec.rb spec/c                       ore/style/rd_style_spec.rb spec/core/style/tdiary_style_spec.rb spec/core/style/wiki_style_spec.rb spec/plugin/bq_spec.rb
      0 [main] ruby 5544 child_info_fork::abort: address space needed by 'etc.so' (0x340000) is already occupied
      0 [main] ruby 5924 child_info_fork::abort: address space needed by 'etc.so' (0x340000) is already occupied
      1 [main] ruby 2288 child_info_fork::abort: address space needed by 'etc.so' (0x340000) is already occupied
      1 [main] ruby 3412 child_info_fork::abort: address space needed by 'etc.so' (0x340000) is already occupied
      1 [main] ruby 2140 child_info_fork::abort: address space needed by 'etc.so' (0x340000) is already occupied
      0 [main] ruby 5308 child_info_fork::abort: address space needed by 'etc.so' (0x340000) is already occupied
/usr/local/lib/ruby/1.9.1/yaml.rb:56:in `<top (required)>':
It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your ruby.

返ってこない

_ [ruby][bundle]bundle install --path ~/.bundle するといろいろ怒られる

% uname -a
NetBSD mogu.area51.gr.jp 5.99.58 NetBSD 5.99.58 (MYKERNEL) #0: Mon Dec 26 21:16:57 JST 2011  root@mogu.area51.gr.jp:/usr/obj/sys/arch/i386/compile/MYKERNEL i386
% ruby --version
ruby 1.9.2p180 (2011-02-18 revision 30909) [i386-netbsdelf]
% gem --version
1.3.7
% bundle install --path ~/.bundle
Fetching source index for http://rubygems.org/
Using rake (0.9.2.2)
Using addressable (2.2.6)
Using highline (1.6.11)
Using net-ssh (2.3.0)
Using net-scp (1.0.4)
Using net-sftp (2.0.5)
Using net-ssh-gateway (1.1.0)
Using capistrano (2.9.0)
Using capistrano_colors (0.5.5)
Using mime-types (1.17.2)
Using nokogiri (1.5.0)
Using rack (1.4.1)
Using rack-test (0.6.1)
Using ffi (1.0.11)
Using childprocess (0.3.0)
Using multi_json (1.0.4)
Using rubyzip (0.9.5)
Using selenium-webdriver (2.17.0)
Using xpath (0.1.4)
Using capybara (1.1.2)
Using net-http-digest_auth (1.2)
Using net-http-persistent (1.9)
Using webrobots (0.0.13)
Using mechanize (2.0.1)
Using capybara-mechanize (0.3.0.rc3)
Using coffee-script-source (1.2.0)
Using execjs (1.3.0)
Using coffee-script (2.2.0)
Using daemons (1.1.6)
Using diff-lcs (1.1.3)
Installing eventmachine (0.12.10) with native extensions /usr/pkg/lib/ruby/1.9/rubygems/installer.rb:496:in `rescue in block in build_extensions': E
RROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)

/usr/pkg/bin/ruby19 extconf.rb
checking for rb_trap_immediate in ruby.h,rubysig.h... no
checking for rb_thread_blocking_region()... yes
checking for inotify_init() in sys/inotify.h... no
checking for __NR_inotify_init in sys/syscall.h... no
checking for writev() in sys/uio.h... yes
checking for rb_thread_check_ints()... yes
checking for rb_time_new()... yes
checking for sys/event.h... yes
checking for sys/queue.h... yes
checking for main() in -lssl... yes
checking for main() in -lcrypto... yes
checking for openssl/ssl.h... yes
checking for openssl/err.h... yes
creating Makefile

make
c++ -I. -I/usr/pkg/include/ruby-1.9/i386-netbsdelf -I/usr/pkg/include/ruby-1.9/ruby/backward -I/usr/pkg/include/ruby-1.9 -I. -DBUILD_FOR_RUBY -DHAVE_RB_THREAD_BLOCKING_REGION -DHAVE_TBR -DHAVE_WRITEV -DHAVE_WRITEV -DHAVE_RB_THREAD_CHECK_INTS -DHAVE_RB_TIME_NEW -DOS_UNIX -DHAVE_SYS_EVENT_H -DHAVE_SYS_QUEUE_H -DHAVE_KQUEUE -DHAVE_OPENSSL_SSL_H -DHAVE_OPENSSL_ERR_H -DWITH_SSL -DHAVE_MAKE_PAIR -I/usr/include   -fPIC -O2 -pthread -I/usr/include -fPIC -pipe -O2 -pthread -I/usr/include -obinder.o -c binder.cpp
c++ -I. -I/usr/pkg/include/ruby-1.9/i386-netbsdelf -I/usr/pkg/include/ruby-1.9/ruby/backward -I/usr/pkg/include/ruby-1.9 -I. -DBUILD_FOR_RUBY -DHAVE_RB_THREAD_BLOCKING_REGION -DHAVE_TBR -DHAVE_WRITEV -DHAVE_WRITEV -DHAVE_RB_THREAD_CHECK_INTS -DHAVE_RB_TIME_NEW -DOS_UNIX -DHAVE_SYS_EVENT_H -DHAVE_SYS_QUEUE_H -DHAVE_KQUEUE -DHAVE_OPENSSL_SSL_H -DHAVE_OPENSSL_ERR_H -DWITH_SSL -DHAVE_MAKE_PAIR -I/usr/include   -fPIC -O2 -pthread -I/usr/include -fPIC -pipe -O2 -pthread -I/usr/include -ocmain.o -c cmain.cpp
c++ -I. -I/usr/pkg/include/ruby-1.9/i386-netbsdelf -I/usr/pkg/include/ruby-1.9/ruby/backward -I/usr/pkg/include/ruby-1.9 -I. -DBUILD_FOR_RUBY -DHAVE_RB_THREAD_BLOCKING_REGION -DHAVE_TBR -DHAVE_WRITEV -DHAVE_WRITEV -DHAVE_RB_THREAD_CHECK_INTS -DHAVE_RB_TIME_NEW -DOS_UNIX -DHAVE_SYS_EVENT_H -DHAVE_SYS_QUEUE_H -DHAVE_KQUEUE -DHAVE_OPENSSL_SSL_H -DHAVE_OPENSSL_ERR_H -DWITH_SSL -DHAVE_MAKE_PAIR -I/usr/include   -fPIC -O2 -pthread -I/usr/include -fPIC -pipe -O2 -pthread -I/usr/include -ocplusplus.o -c cplusplus.cpp
c++ -I. -I/usr/pkg/include/ruby-1.9/i386-netbsdelf -I/usr/pkg/include/ruby-1.9/ruby/backward -I/usr/pkg/include/ruby-1.9 -I. -DBUILD_FOR_RUBY -DHAVE_RB_THREAD_BLOCKING_REGION -DHAVE_TBR -DHAVE_WRITEV -DHAVE_WRITEV -DHAVE_RB_THREAD_CHECK_INTS -DHAVE_RB_TIME_NEW -DOS_UNIX -DHAVE_SYS_EVENT_H -DHAVE_SYS_QUEUE_H -DHAVE_KQUEUE -DHAVE_OPENSSL_SSL_H -DHAVE_OPENSSL_ERR_H -DWITH_SSL -DHAVE_MAKE_PAIR -I/usr/include   -fPIC -O2 -pthread -I/usr/include -fPIC -pipe -O2 -pthread -I/usr/include -oed.o -c ed.cpp
c++ -I. -I/usr/pkg/include/ruby-1.9/i386-netbsdelf -I/usr/pkg/include/ruby-1.9/ruby/backward -I/usr/pkg/include/ruby-1.9 -I. -DBUILD_FOR_RUBY -DHAVE_RB_THREAD_BLOCKING_REGION -DHAVE_TBR -DHAVE_WRITEV -DHAVE_WRITEV -DHAVE_RB_THREAD_CHECK_INTS -DHAVE_RB_TIME_NEW -DOS_UNIX -DHAVE_SYS_EVENT_H -DHAVE_SYS_QUEUE_H -DHAVE_KQUEUE -DHAVE_OPENSSL_SSL_H -DHAVE_OPENSSL_ERR_H -DWITH_SSL -DHAVE_MAKE_PAIR -I/usr/include   -fPIC -O2 -pthread -I/usr/include -fPIC -pipe -O2 -pthread -I/usr/include -oem.o -c em.cpp
em.cpp: In member function 'void EventMachine_t::_ReadLoopBreaker()':
em.cpp:924: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'bool EventMachine_t::_RunTimers()':
em.cpp:948: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'const long unsigned int EventMachine_t::ConnectToServer(const char*, int, const char*, int)':
em.cpp:1089: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'const long unsigned int EventMachine_t::ConnectToUnixServer(const char*)':
em.cpp:1218: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1221: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1237: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1243: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1249: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'int EventMachine_t::DetachFD(EventableDescriptor*)':
em.cpp:1350: error: invalid conversion from 'EventableDescriptor*' to '__intptr_t'
em.cpp: In member function 'const long unsigned int EventMachine_t::CreateTcpServer(const char*, int)':
em.cpp:1453: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1455: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1535: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'const long unsigned int EventMachine_t::OpenDatagramSocket(const char*, int)':
em.cpp:1545: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1596: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'void EventMachine_t::ArmKqueueWriter(EventableDescriptor*)':
em.cpp:1625: error: invalid conversion from 'EventableDescriptor*' to '__intptr_t'
em.cpp: In member function 'void EventMachine_t::ArmKqueueReader(EventableDescriptor*)':
em.cpp:1647: error: invalid conversion from 'EventableDescriptor*' to '__intptr_t'
em.cpp: In member function 'const long unsigned int EventMachine_t::_OpenFileForWriting(const char*)':
em.cpp:1773: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'const long unsigned int EventMachine_t::CreateUnixDomainServer(const char*)':
em.cpp:1805: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1866: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'const long unsigned int EventMachine_t::Socketpair(char* const*)':
em.cpp:1927: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1932: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1934: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1938: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1948: warning: converting to non-pointer type 'long unsigned int' from NULL
*** Error code 1

Stop.
make: stopped in /usr/pkg/lib/ruby/gems/1.9/gems/eventmachine-0.12.10/ext


Gem files will remain installed in /usr/pkg/lib/ruby/gems/1.9/gems/eventmachine-0.12.10 for inspection.
Results logged to /usr/pkg/lib/ruby/gems/1.9/gems/eventmachine-0.12.10/ext/gem_make.out

? ('A`)

ググる

#79: invalid conversion from 'EventableDescriptor*' to '__intptr_t' - Issues - eventmachine/eventmachine - GitHub

pkgsrc にある....だと...?

% cd /usr/pkgsrc/devel/ruby-eventmachine/
% sudo make install clean clean-depends

まだ同じだった

一度アンインストール

% sudo gem uninstall bundler

pkgsrc のほうのをインストールしてみる。

% cd /usr/pkgsrc/misc/ruby-bundler/
% sudo make install clean clean-depends
if /usr/sbin/pkg_info -K /var/db/pkg -qe "ruby18-bundler-[0-9]*"; then  /usr/sbin/pkg_info -K /var/db/pkg -qr "ruby18-bundler-[0-9]*" > /usr/pkgsrc/
misc/ruby-bundler/work/.DLIST;  else  /usr/bin/touch /usr/pkgsrc/misc/ruby-bundler/work/.DLIST;  fi
===> Deinstalling for ruby18-bundler-1.0.15

いや ruby18 ちゃうねん

@miwarin Ruby はインストールされてるバージョンは見ないで、RUBY_VERSION_DEFAULT で指定されてるやつを使いますので。192 か 193 か、お望みの方を指定すればよろしいかと。( @obache )

オス

% sudo make RUBY_VERSION_DEFAULT=192 install

とやったら 1.8 がインストールされた。

あら

% grep -r RUBY_VERSION_DEFAULT /usr/pkgsrc/lang/*
ruby/rubyversion.mk:# RUBY_VERSION_DEFAULT defines default version for Ruby related
ruby/rubyversion.mk:RUBY_VERSION_DEFAULT?=      1.8
ruby/rubyversion.mk:_RUBY_VERSION_DEFAULT=      ${RUBY_VERSION_DEFAULT:S/.//}
ruby/rubyversion.mk:#   Default value is set to ${RUBY_VERSION_DEFAULT}
ruby/rubyversion.mk:.  if ${RUBY_VERSION_DEFAULT} == "1.8"
ruby/rubyversion.mk:.  elif ${RUBY_VERSION_DEFAULT} == "1.9"
ruby/rubyversion.mk:MULTI+=     RUBY_VERSION_REQD=${RUBY_VERSION_REQD:U${_RUBY_VERSION_DEFAULT}}
ruby/rubyversion.mk:                    RUBY_VERSION_DEFAULT=${RUBY_VERSION_DEFAULT:Q}
ruby/rubyversion.mk:                    RUBY_VERSION_DEFAULT=${RUBY_VERSION_DEFAULT:Q}

1.9 ?

やってみる

% sudo make RUBY_VERSION_DEFAULT=1.9 install clean clean-depends
=> Bootstrap dependency digest>=20010302: found digest-20080510
=> Checksum SHA1 OK for bundler-1.0.15.gem
=> Checksum RMD160 OK for bundler-1.0.15.gem
===> Installing dependencies for ruby19-bundler-1.0.15
==========================================================================
The following variables will affect the build process of this package,
ruby19-bundler-1.0.15.  Their current value is shown below:

        * BDB185_DEFAULT = db1
        * BDB_DEFAULT = db4
        * SSLBASE = /usr
        * SSLCERTS = /etc/openssl/certs
        * SSLDIR = /etc/openssl
        * SSLKEYS = /etc/openssl/private

Based on these variables, the following variables have been set:

        * BDBBASE = /usr
        * BDB_LIBS (defined, but empty)
        * BDB_TYPE = db1

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
==========================================================================
=> Build dependency checkperms>=1.1: found checkperms-1.11
=> Full dependency ruby19-base>=1.9.2: found ruby19-base-1.9.2pl180nb2
===> Overriding tools for ruby19-bundler-1.0.15
===> Extracting for ruby19-bundler-1.0.15
Unpacked gem: '/usr/pkgsrc/misc/ruby-bundler/work/bundler-1.0.15'
===> Patching for ruby19-bundler-1.0.15
===> Creating toolchain wrappers for ruby19-bundler-1.0.15
===> Configuring for ruby19-bundler-1.0.15
=> Checking for portability problems in extracted files
===> Building for ruby19-bundler-1.0.15
=> Removing backup files of patch before build
  Successfully built RubyGem
  Name: bundler
  Version: 1.0.15
  File: bundler-1.0.15.gem
=> Unwrapping files-to-be-installed.
INFO: [subst.mk:unwrap] Nothing changed in ./lib/bundler/man/bundle-config.
===> Installing for ruby19-bundler-1.0.15
=> Generating pre-install file lists
=> Installing gem into installation root
Successfully installed bundler-1.0.15
1 gem installed
Installing ri documentation for bundler-1.0.15...
Installing RDoc documentation for bundler-1.0.15...
=> Cleaning intermediate gem build files
=> gem install
=> Automatic manual page handling
=> Generating post-install file lists
=> Checking file-check results for ruby19-bundler-1.0.15
=> Checking for non-existent script interpreters in ruby19-bundler-1.0.15
=> Checking file permissions in ruby19-bundler-1.0.15
=> Checking for missing run-time search paths in ruby19-bundler-1.0.15
=> Checking for work-directory references in ruby19-bundler-1.0.15
===> Building binary package for ruby19-bundler-1.0.15
=> Creating binary package /usr/pkgsrc/packages/All/ruby19-bundler-1.0.15.tgz
===> Install binary package of ruby19-bundler-1.0.15

おk

eventmachine も ruby 1.9 でインストールしなおす

% cd /usr/pkgsrc/devel/ruby-eventmachine
% sudo make RUBY_VERSION_DEFAULT=1.9 install clean clean-depends

bundle してみる

やはり同じエラー ('A`)

% bundle install --path ~/.bundle
THREAD_BLOCKING_REGION -DHAVE_TBR -DHAVE_WRITEV -DHAVE_WRITEV -DHAVE_RB_THREAD_CHECK_INTS -DHAVE_RB_TIME_NEW -DOS_UNIX -DHAVE_SYS_EVENT_H -DHAVE_SYS_QUEUE_H -DHAVE_KQUEUE -DHAVE_OPENSSL_SSL_H -DHAVE_OPENSSL_ERR_H -DWITH_SSL -DHAVE_MAKE_PAIR -I/usr/include   -fPIC -O2 -pthread -I/usr/include -fPIC -pipe -O2 -pthread -I/usr/include -oem.o -c em.cpp
em.cpp: In member function 'void EventMachine_t::_ReadLoopBreaker()':
em.cpp:924: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'bool EventMachine_t::_RunTimers()':
em.cpp:948: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'const long unsigned int EventMachine_t::ConnectToServer(const char*, int, const char*, int)':
em.cpp:1089: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'const long unsigned int EventMachine_t::ConnectToUnixServer(const char*)':
em.cpp:1218: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1221: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1237: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1243: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1249: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'int EventMachine_t::DetachFD(EventableDescriptor*)':
em.cpp:1350: error: invalid conversion from 'EventableDescriptor*' to '__intptr_t'
em.cpp: In member function 'const long unsigned int EventMachine_t::CreateTcpServer(const char*, int)':
em.cpp:1453: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1455: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1535: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'const long unsigned int EventMachine_t::OpenDatagramSocket(const char*, int)':
em.cpp:1545: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1596: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'void EventMachine_t::ArmKqueueWriter(EventableDescriptor*)':
em.cpp:1625: error: invalid conversion from 'EventableDescriptor*' to '__intptr_t'
em.cpp: In member function 'void EventMachine_t::ArmKqueueReader(EventableDescriptor*)':
em.cpp:1647: error: invalid conversion from 'EventableDescriptor*' to '__intptr_t'
em.cpp: In member function 'const long unsigned int EventMachine_t::_OpenFileForWriting(const char*)':
em.cpp:1773: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'const long unsigned int EventMachine_t::CreateUnixDomainServer(const char*)':
em.cpp:1805: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1866: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp: In member function 'const long unsigned int EventMachine_t::Socketpair(char* const*)':
em.cpp:1927: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1932: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1934: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1938: warning: converting to non-pointer type 'long unsigned int' from NULL
em.cpp:1948: warning: converting to non-pointer type 'long unsigned int' from NULL
*** Error code 1

Stop.
make: stopped in /home/rin/.bundle/ruby/1.9/gems/eventmachine-0.12.10/ext


Gem files will remain installed in /home/rin/.bundle/ruby/1.9/gems/eventmachine-0.12.10 for inspection.
Results logged to /home/rin/.bundle/ruby/1.9/gems/eventmachine-0.12.10/ext/gem_make.out
        from /usr/pkg/lib/ruby/1.9/rubygems/installer.rb:499:in `block in build_extensions'
        from /usr/pkg/lib/ruby/1.9/rubygems/installer.rb:459:in `each'
        from /usr/pkg/lib/ruby/1.9/rubygems/installer.rb:459:in `build_extensions'
        from /usr/pkg/lib/ruby/1.9/rubygems/installer.rb:207:in `install'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/source.rb:101:in `block in install'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/rubygems_integration.rb:78:in `preserve_paths'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/source.rb:91:in `install'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/installer.rb:58:in `block (2 levels) in run'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/rubygems_integration.rb:93:in `with_build_args'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/installer.rb:57:in `block in run'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/spec_set.rb:12:in `block in each'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/spec_set.rb:12:in `each'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/spec_set.rb:12:in `each'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/installer.rb:49:in `run'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/installer.rb:8:in `install'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/cli.rb:222:in `install'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/vendor/thor/task.rb:22:in `run'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/vendor/thor/invocation.rb:118:in `invoke_task'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/vendor/thor.rb:246:in `dispatch'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/lib/bundler/vendor/thor/base.rb:389:in `start'
        from /usr/pkg/lib/ruby/gems/1.9/gems/bundler-1.0.15/bin/bundle:13:in `<top (required)>'
        from /usr/pkg/bin/bundle:19:in `load'
        from /usr/pkg/bin/bundle:19:in `<main>'

@miwarin あ、2011Q4 ですか。current では1.9という指定は廃止されてるので、192 を使うようにしておくのがいいようです。あと、コマンドラインで一発設定なら RUBY_VERSION_REQD に、でもいいですね。( @obache )

ぐふう

本日のツッコミ(全2件) [ツッコミを入れる]
_ hsbt (2012-02-16 07:50)

bundle install --path ~/.bundle --without development<br>だとどうですかね

_ みわ (2012-02-17 23:57)

ありがとうゴマス。いけました。<br>意味は分かってないです ('A`)